Was tun bei Problemen mit der Medienverwaltung

Frage

Ich habe Probleme bei der Nutzung der Medienverwaltung.
Es tritt mindestens eines der folgenden Symptome auf.

  • Ich erhalte die Fehlermeldung "Unbekannter Fehler" bzw. "Unknown Error".
  • Wenn ich die Medienverwaltung aufrufe erhalte ich nur eine weiße Seite.
  • Wenn ich einen Ordner in der Medienverwaltung öffne, werden nicht alle Thumbnails (Vorschaubilder) angezeigt.

Wie kann ich diese Fehler beheben?

Ursachen

Folgende Fehlerursachen sind die häufigsten Quellen für die oben genannten Probleme:

  • Nicht korrekt gesetzte Dateirechte
  • Maximale Uploadgröße ist nicht hoch genug
  • Es ist ein Server-Modul zum Schutzen vor DoS (Denial of Service) Angriffen aktiviert (z.B. mod_evasive).

Lösung

Dateiberechtigungen korrigieren

Stellen Sie sicher das die folgenden Ordner und alle darin enthaltenen Dateien und Unterordner für den Webserver lesbar und beschreibbar sind.

ULICMS_DATA_STORAGE_ROOT steht für das Datenverzeichnis von UliCMS, das ist in der Regel der Ordner, in dem das CMS installiert ist.

  • ULICMS_DATA_STORAGE_ROOT/content/images
  • ULICMS_DATA_STORAGE_ROOT/content/files
  • ULICMS_DATA_STORAGE_ROOT/content/.thumbs

Maximale Größe für Uploads erhöhen

Wenn Sie besonders große Dateien oder viele Dateien auf ein mal hochladen möchten und dies fehlschägt, müssen Sie die maximale Größe für Dateiuploads vergrößern.

In folgendem Artikel wird beschrieben, wie dies zu korrigieren ist (Siehe Abschnitt "Lösung").

Probleme mit DoS-Schutz (mod_evasive) beheben

Wenn in der Medienverwaltung manche Thumbnails (Vorschaubilder) nicht angezeigt werden, kann dass daran liegen, das eine Software zum Schutz vor DoS Angriffen auf dem Server installiert ist und diese fälschlicherweise die Requests, zum Laden der Thumbnails blockiert.
Stellen Sie in diesem Fall die Sicherheitssoftware weniger restriktiv ein.

Wenn Sie den Apache Webserver nutzen und das Modul mod_evasive aktiviert ist, lesen Sie bitte folgenden Artikel.

Identifying and fixing mod_evasive "client denied by server configuration" errors

Don't click this link